Technical Requirements – Mobius MD – Modern Medicine

Technical Requirements

Internet Access

Please ensure you have access to internet via wi-fi or a cellular network.

Smartphones & Tablets

Our apps work on Apple iPhones, iPod Touches, and iPads. The minimum version that is secure enough is iOS 8. See our complete list of compatible devices.

iPhone
  • iPhone 6s (+)
  • iPhone 6 (+)
  • iPhone 5s
  • iPhone 5
  • iPhone 4s
iPod Touch
  • 6th Generation:
    • Model Number: A1574
  • 5th Generation:
    • Model Number: A1509
    • Model Number: A1421
iPad
  • iPad Pro
  • iPad Air 2
  • iPad Air
  • iPad mini 2-4
  • iPad mini
  • iPad (4th generation)
  • iPad (3rd geneartion)
Desktop
(Mobius Capture Only)
  • Mac OS
  • Windows 7/8/9/10

EMR / EHR

Our apps integrate with several EMRs / EHRs.

Dont see your EMR?
pic pic pic pic pic